Results 1 to 4 of 4

Thread: 4L80 question

  1. #1
    Lifetime Member
    Join Date
    Sep 2003
    Posts
    688

    Default 4L80 question

    A week ago I had a customer put a 4L80 in a 2002 Camaro. I copied the transmission calibration, diagnostics and the speedo segment from a 6.0 Silverado with this tranny. The tranny have a manual valve body in it and the problem is when you are drving the car it shift from first to third even if the car is pulled down into 1st gear. Did i miss something when i copied the segment from the Silvy
    EFILive - The Single version of the Truth

    Larry - HumpinSS

  2. #2
    EFILive Distributor dfe1's Avatar
    Join Date
    Jan 2005
    Posts
    837

    Default

    If it has a manual valve body, then whatever you do in the trans calibration/diagnostic tables should have no effect. If it's shifting from 1st to 3rd when you move the lever, then either the detents are not set correctly or there's a problem with the valve body itself. If the car shifts automatically at all, I think the valve body conversion wasn't done correctly, because they typically eliminate all aspects of automatic gear change.
    DigitalEFI- EFILive US Distributor
    sales@digitalefi.com
    678/344-1590

  3. #3
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,192

    Default

    Is it throwing any DTC's...?

  4. #4
    Lifetime Member
    Join Date
    Sep 2003
    Posts
    688

    Default

    Not that i know of joecar I was posting this for a friend. and dfe1 maybe that is the issue I will see if i can get him around to chime in with more information
    EFILive - The Single version of the Truth

    Larry - HumpinSS

Similar Threads

  1. 4L80 no tcc lock up
    By E.R. Racing in forum Vortec V6/V8 Specific
    Replies: 10
    Last Post: October 13th, 2009, 04:35 PM
  2. 4L80 wiring
    By ebayer5 in forum General (Petrol, Gas, Ethanol)
    Replies: 0
    Last Post: August 5th, 2009, 11:24 PM
  3. From a M6 to 4L80 speedometer problem
    By RandyWS6 in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 3
    Last Post: April 6th, 2009, 11:12 AM
  4. 4L80-E stuck in 2nd
    By jpsxpress in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 0
    Last Post: January 3rd, 2008, 03:12 PM
  5. 91 K2500 4l80 gets stuck in 2nd
    By amh in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 4
    Last Post: December 30th, 2007, 09:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •