Results 1 to 6 of 6

Thread: 2011 LML Cruise Control

  1. #1
    Member
    Join Date
    Mar 2022
    Posts
    64

    Default 2011 LML Cruise Control

    Recently tuned a "lightweight" LML, and lost cruise control afterward. The truck had an H&S programmer previously, and cruise worked with it. These are the file segments:

    Segment Description Part# Checksum Comments
    Boot Software 12646251 $60F19343
    Secondary Operating System 12646250 $4FE0608C
    Main Operating System 12646249 $1167F5E0
    Engine 12655862 $5B04914D
    Speedometer 12646363 $373AA8B5
    System 12655886 $CBF1C486
    Fuel System 12646324 $EB6F405E
    Engine Diagnostic 12655870 $3509C5C4
    Engine Operation 12655864 $B1AE0F45

    I've tried various combinations under Vehicle Options > Parameters, but no luck so far.

    Can anyone help me out here? I can send the tune in private message, but I prefer not to post it.

  2. #2
    Junior Member
    Join Date
    Sep 2013
    Posts
    11

    Default

    I had this same thing happen on OS 12649244. I had to fiddle with the CAN communications to get it to work.
    It ended up being one of the "BLOx" sensors. Turned communication back on, and the cruise started working again.

  3. #3
    Member
    Join Date
    Mar 2022
    Posts
    64

    Default

    Thanks. I'll try that.

  4. #4
    Member
    Join Date
    Mar 2022
    Posts
    64

    Default

    Finally got to work on the truck again. Ended up being some speed limiters I set wrong. I believe B0603 is for cruise control, if I'm not mistaken. This is how I ended up setting the table

    Click image for larger version. 

Name:	Screenshot 2024-04-12 221610.png 
Views:	61 
Size:	141.6 KB 
ID:	24596

  5. #5
    New Member
    Join Date
    Aug 2021
    Posts
    4

    Default

    Quote Originally Posted by Omega_5 View Post
    I had this same thing happen on OS 12649244. I had to fiddle with the CAN communications to get it to work.
    It ended up being one of the "BLOx" sensors. Turned communication back on, and the cruise started working again.
    im having problems with it working but turns off by itself in diffrent time intervalls.


    you know exactly what Nox sensor CAN table to re activate?

  6. #6
    Junior Member
    Join Date
    Sep 2013
    Posts
    11

    Default

    It's best to leave them all enabled, unless you're getting dash messages.

Similar Threads

  1. 2011 cab and chassis. No cruise control
    By Sass5150 in forum Cummins 6.7L
    Replies: 1
    Last Post: May 9th, 2023, 04:12 AM
  2. 2011 lml 2500 W/T - No Cruise from Factory
    By wheresbrent in forum Duramax 2011+ LML / LGH
    Replies: 2
    Last Post: February 2nd, 2021, 03:25 PM
  3. ABS, Traction control, Cruise control..
    By GMCAMARO in forum Gen III V8 Specific
    Replies: 5
    Last Post: January 23rd, 2016, 03:10 PM
  4. LML Cruise control intermittant after flashing
    By shane in forum Duramax 2011+ LML / LGH
    Replies: 8
    Last Post: December 22nd, 2015, 04:15 AM
  5. Lean Cruise and Cruise Control
    By neil in forum Tuning For Economy
    Replies: 11
    Last Post: July 9th, 2007, 09:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •