Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Speedo Calculator issues...Help Please

  1. #1

    Default Speedo Calculator issues...Help Please

    Ok.

    I am trying to get a 2000 T/A dialed in correctly. I have the tune spot on, but shift points and the speedo are off. Obviously I want to get the speedo sense and accuracy correct before I adjust shift points. The owner of the car installed 3.73 gears and a 3500RPM stall.

    This is what is happening.

    I am entering the tire size and gear ratio into the calculator.

    275/40/17 and gear ratio of 3.73.

    The calc wants to give values of:

    TOS rev/mile = 2931.52
    Pulse/mile of = 117261

    The stock numbers are:

    TOS rev/mile = 2615.3906
    Pulse/mile of = 104612

    The cars speedo shows 61 MPH and both my dyno and GPS says 54 MPH.

    If I try to manually enter a number higher than 107239 it reverts back to 107239. It will accept the 2931.52 TOS value, but not the Pulse/mile speedo correction.

    When I apply the numbers generated by the speedo calculator it holds the 107239 value and allows the TOS value.

    The EFI-Live version of my V2 is V7.4.2 Build 622

    Obviously the lower the Pulse/Mile value the faster the speedo will read over actual so how do I compensate without throwing the shaft revs per mile off?

    Thanks much!
    -Kenny
    Your friendly Colorado Springs EfiLive cheerleader!!

  2. #2
    Lifetime Member SSpdDmon's Avatar
    Join Date
    Jun 2005
    Posts
    1,556

    Default

    I noticed a similar issue with this in my v.7.3.2 as well (still running flashscan v.1).

    My '02 f-body (OS 12212156) had a max of 253436 VSS pulses/min. However, my friend's '00 f-body (OS 09381344) has a max of only 129759 VSS pulses/min. The problem is, that's not enough to cover the 132303 pulses/min his 4.10's need to report the speed accurately. Why is this limited so low when my '02 didn't have this restriction?


    Sorry to hijack...

  3. #3
    Lifetime Member eboggs_jkvl's Avatar
    Join Date
    Apr 2004
    Posts
    757

    Default

    Yeah yeah, I know, I have the bastard 98 POS but I just tried your numbers

    I entered

    275 40 17
    Clicked on recalculate

    Entered final drive ratio of 3.73

    TOS ia 2931.52 P/M = 49836

    Clicked on "apply", "close"

    Now I show
    VSS 49835.9
    TOS 2931.5242

    When I do my setup 275 30 19 3.73 I get:
    VSS = 50159.1
    TOS = 2950.5366


    Are we doing the same steps or is it the OS with a bug? My speedo is spot on for my setup. I'm running V2 V7.4

    Elmer

  4. #4

    Default

    I spoke with the kind folks at RedLine (Thank you Howard) and we tried entering the same numbers you said at 49835.9 (49836) and the same TOS. The speedo went to 60 or 70 MPH (I don't remember now) and the dyno showed 25MPH actual.

    With the numbers the speedo calc is trying to generate for Pulse/mile and calculating actual MPH compared to displayed...the percentage is correct to send the Pulse/mile up to 117261 to get a proper speedo displayed to actual speed.

  5. #5
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,305

    Default

    Make sure you have entered the tire size correctly. Actually it would be better to measure the rolling circumference of the tire (the distance travelled -in inches - in one wheel revolution) and enter that in the circumference field in the speedo calculator.

    The limit for H0101 (for 200 TA) is 230396, so ther eshould be no problem entering 117261, see attached screen shot.

    Regards
    Paul

    Quote Originally Posted by KAZ MotorSports
    Ok.

    I am trying to get a 2000 T/A dialed in correctly. I have the tune spot on, but shift points and the speedo are off. Obviously I want to get the speedo sense and accuracy correct before I adjust shift points. The owner of the car installed 3.73 gears and a 3500RPM stall.

    This is what is happening.

    I am entering the tire size and gear ratio into the calculator.

    275/40/17 and gear ratio of 3.73.

    The calc wants to give values of:

    TOS rev/mile = 2931.52
    Pulse/mile of = 117261

    The stock numbers are:

    TOS rev/mile = 2615.3906
    Pulse/mile of = 104612

    The cars speedo shows 61 MPH and both my dyno and GPS says 54 MPH.

    If I try to manually enter a number higher than 107239 it reverts back to 107239. It will accept the 2931.52 TOS value, but not the Pulse/mile speedo correction.

    When I apply the numbers generated by the speedo calculator it holds the 107239 value and allows the TOS value.

    The EFI-Live version of my V2 is V7.4.2 Build 622

    Obviously the lower the Pulse/Mile value the faster the speedo will read over actual so how do I compensate without throwing the shaft revs per mile off?

    Thanks much!
    -Kenny
    Your friendly Colorado Springs EfiLive cheerleader!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Image1.png 
Views:	236 
Size:	82.7 KB 
ID:	1637  
    Before asking for help, please read this.

  6. #6
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,305

    Default

    I believe H0105 or H0106 output drives the speedo (the other is for ABS I think), so you should be able to change one of those to alter the speedo needle without affecting the rest of the speedo calibrations

    If you have a PCM pinout, lookup what the PCM pins are linked to:
    H0105: J2-Pin 50
    H0106: J2-Pin 49
    If one of them is outputting to the speedo/cluster then try adjusting that.

    Regards
    Paul

    Quote Originally Posted by KAZ MotorSports
    Obviously the lower the Pulse/Mile value the faster the speedo will read over actual so how do I compensate without throwing the shaft revs per mile off?

    Thanks much!
    -Kenny
    Your friendly Colorado Springs EfiLive cheerleader!!
    Before asking for help, please read this.

  7. #7

    Default

    Looking at mine it says the maximum is 66587 where you have yours highlighted.

    I do not know how to take a screenshot to post like you showed sorry.

  8. #8
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,305

    Default

    Probably a difference between Auto and manual transmissions. 40 v's 17 teeth on the VSS pickup.

    Regards
    Paul

    Quote Originally Posted by eboggs_jkvl
    Yeah yeah, I know, I have the bastard 98 POS but I just tried your numbers

    I entered

    275 40 17
    Clicked on recalculate

    Entered final drive ratio of 3.73

    TOS ia 2931.52 P/M = 49836

    Clicked on "apply", "close"

    Now I show
    VSS 49835.9
    TOS 2931.5242

    When I do my setup 275 30 19 3.73 I get:
    VSS = 50159.1
    TOS = 2950.5366


    Are we doing the same steps or is it the OS with a bug? My speedo is spot on for my setup. I'm running V2 V7.4

    Elmer
    Before asking for help, please read this.

  9. #9
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,305

    Default

    Email me your *.tun file to paul@efilive.com
    I'll take a close look.
    Paul

    Quote Originally Posted by KAZ MotorSports
    Looking at mine it says the maximum is 66587 where you have yours highlighted.

    I do not know how to take a screenshot to post like you showed sorry.
    Before asking for help, please read this.

  10. #10

    Default

    I just "measured" the tire circ and with a line wrapped around the tire and then with a tape measure it was 81". The calculator shows 80.62" so I would say that is close enough.

    *edit* Paul I just sent you the file.

    -Kenny
    Last edited by KAZ MotorSports; May 7th, 2007 at 10:25 AM.

Page 1 of 3 123 LastLast

Similar Threads

  1. Speedo-Calculator ?
    By GAMEOVER in forum General (Petrol, Gas, Ethanol)
    Replies: 12
    Last Post: April 3rd, 2014, 10:32 AM
  2. problems with the speedo calculator
    By goldbergv95 in forum LL8 4.2L In-Line 6 - P10 PCM
    Replies: 18
    Last Post: December 19th, 2008, 10:34 AM
  3. LMM Speedo Calculator
    By Redline Motorsports in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 2
    Last Post: April 28th, 2008, 06:51 AM
  4. need help with SPEEDO CALCULATOR
    By Boost in forum General (Diesel)
    Replies: 9
    Last Post: October 17th, 2007, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •