Results 1 to 7 of 7

Thread: Service vehicle light with custom os?

  1. #1
    Senior Member
    Join Date
    Feb 2006
    Posts
    113

    Default Service vehicle light with custom os?

    Tried a search and came up dry. Put in a 0202003 OS in a 2002 Z28. Car runs fine but the service vehicle light is on and won't clear.

    Whats my problem? I'm thinking of switching to a 2001 custom OS. Just don't have much time to keep burning.

  2. #2
    Lifetime Member
    Join Date
    Aug 2005
    Posts
    710

    Default

    Quote Originally Posted by slowhawk
    Tried a search and came up dry. Put in a 0202003 OS in a 2002 Z28. Car runs fine but the service vehicle light is on and won't clear.

    Whats my problem? I'm thinking of switching to a 2001 custom OS. Just don't have much time to keep burning.
    Have you read the DTCs to see what the problem is? Perhaps there are MILs that are enabled in the 02 OS that are disabled in the 01.

    Justin

  3. #3
    Senior Member
    Join Date
    Feb 2006
    Posts
    113

    Default

    Quote Originally Posted by dc_justin
    Have you read the DTCs to see what the problem is? Perhaps there are MILs that are enabled in the 02 OS that are disabled in the 01.

    Justin
    Only DTC is the MAF which is normal. It's a service vehicle,not an engine light.When you clear the codes it comes up right away again.

  4. #4
    EFILive Reseller wait4me's Avatar
    Join Date
    Aug 2004
    Posts
    1,348

    Default

    does the vin number match your car?
    "If you can leave a black mark on the pavement, from the exit of one corner to the braking point of the next one, you have enough horsepower."

  5. #5
    Lifetime Member Doc's Avatar
    Join Date
    Oct 2005
    Posts
    744

    Default

    That's a good question and I'll add to it...When using the scanner, does the correct VIN appear at the bottom of the page?

    2000 Silverado Full Size 4x4: Forged 6.2, H/C F1R Procharger
    98A4 Z28: 02 PCM H/C Forged 347, 9" Moser 3.73
    V1 V2 99+up RR COS #5 OLSD Dual Stg N20
    www.efialchemy.com
    www.greatamericancarwar.com

  6. #6
    EFILive Reseller wait4me's Avatar
    Join Date
    Aug 2004
    Posts
    1,348

    Default

    Also in the scan tool, if you validate pids and modules, then it should show you the codes for the other modules
    "If you can leave a black mark on the pavement, from the exit of one corner to the braking point of the next one, you have enough horsepower."

  7. #7
    Senior Member
    Join Date
    Feb 2006
    Posts
    113

    Default

    Did a full reflash with the same file and the problem is gone now.Vin # matches.

Similar Threads

  1. Service brake system w/ABS light and Parking Light on
    By mshirshe in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 3
    Last Post: March 13th, 2010, 02:32 AM
  2. Gear Swap and now service brake system/abs light
    By exploder in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 0
    Last Post: May 19th, 2009, 08:04 AM
  3. Great service
    By Chevy366 in forum Lounge
    Replies: 0
    Last Post: April 10th, 2007, 03:15 PM
  4. {B3647} Custom OS Vehicle Criteria
    By Z16DNA in forum General (Petrol, Gas, Ethanol)
    Replies: 0
    Last Post: October 7th, 2005, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •