Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: FAST DUAL O2's

  1. #1
    New Member
    Join Date
    Jan 2007
    Posts
    9

    Default FAST DUAL O2's

    Any chance of a simple PLAIN (still a noobie) English tutorial of how to load the above into V2
    Got it wired into car but there is no PID for it as far as I can see. My tuner has had a go but no joy with it??
    Thanks for any help
    Alan

  2. #2
    Unknown Zone TAQuickness's Avatar
    Join Date
    Jan 2005
    Posts
    2,940

    Default

    Welcome to the forum Alan.

    I do not have hand's on experience with the FAST WB's, but there are a few folks here that have. Perhaps one of them will chime in and share their custom PID's with you.

  3. #3
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    If you post the voltage:AFR conversion points, then someone here can work out a calculated pid for you.

  4. #4
    Member VT LS1 NZ's Avatar
    Join Date
    Apr 2003
    Posts
    79

    Default

    You will find your answers here for setting up a pid:

    http://forum.efilive.com/showthread....=Fast+wideband
    856RWHP 408 Supercharged LS1 Holden Commodore.

  5. #5
    New Member
    Join Date
    Jan 2007
    Posts
    9

    Default

    cheers for that.
    All that means nothing to me???
    I will ring Rosco as he is in UK aswell
    Thanks

  6. #6
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,309

    Default

    any luck? i just bought a dual fast wb setup
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

  7. #7
    Member VT LS1 NZ's Avatar
    Join Date
    Apr 2003
    Posts
    79

    Default

    Quote Originally Posted by minytrker View Post
    any luck? i just bought a dual fast wb setup
    If you have any issues drop me a line & I'll help out.
    856RWHP 408 Supercharged LS1 Holden Commodore.

  8. #8
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,309

    Default

    Quote Originally Posted by VT LS1 NZ View Post
    If you have any issues drop me a line & I'll help out.
    Thanks,

    I had to send it back, it was freezing up on me. I should have another one next week.
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

  9. #9
    Member VT LS1 NZ's Avatar
    Join Date
    Apr 2003
    Posts
    79

    Default

    Is anyone running the RPM kit.
    I bought it last year when it first came out but never got it to work correctly.ie rpms jumping all over the place.
    Tried different pick up pts but still not accurate.
    Didn't bother sending it back,just waiting on a direct connect.
    856RWHP 408 Supercharged LS1 Holden Commodore.

  10. #10
    Member 427's Avatar
    Join Date
    Dec 2007
    Posts
    53

    Question

    Quote Originally Posted by VT LS1 NZ View Post
    Is anyone running the RPM kit.
    I bought it last year when it first came out but never got it to work correctly.ie rpms jumping all over the place.
    Tried different pick up pts but still not accurate.
    Didn't bother sending it back,just waiting on a direct connect.
    i have a fast without the rpm kit- it works a great-

    but i have a b/new fast dual w/band with the rpm kit coming in a week or so what would u like to know-?

    Thanks

    Nick--

Page 1 of 3 123 LastLast

Similar Threads

  1. Dual Fast Wideband
    By minytrker in forum General (Petrol, Gas, Ethanol)
    Replies: 0
    Last Post: February 18th, 2010, 03:37 PM
  2. FAST dual WB to EFI V1
    By rickou812 in forum External A/D inputs
    Replies: 3
    Last Post: November 19th, 2009, 08:06 AM
  3. need help installing fast dual wideband
    By red83 in forum General (Petrol, Gas, Ethanol)
    Replies: 15
    Last Post: December 19th, 2008, 06:01 AM
  4. Anyone try the FAST dual wideband setup?.................
    By FreddyG in forum General (Petrol, Gas, Ethanol)
    Replies: 15
    Last Post: December 23rd, 2007, 04:08 PM
  5. dual fast 90 set up
    By minytrker in forum General (Petrol, Gas, Ethanol)
    Replies: 9
    Last Post: June 7th, 2006, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •