Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Nothing worse then failing emissions on the 31st

  1. #1
    Member
    Join Date
    Dec 2007
    Posts
    61

    Unhappy Nothing worse then failing emissions on the 31st

    Like the title says I didn't pass emissions yesterday, and it was the last day in Oct. :( But it does get worse. In changing things to try to get a tune that will pass I changed something and now my car runs like CRAPOLA!

    Here in Arizona all they do is plug into the computer and check for DTC and system readiness tests, and a visual inspection. I pulled up and he plugged me in and 45 seconds later the printer shot out a paper that said that some of the systems readiness tests were Not Ready they were: Evaporative Purge System, Oxygen Sensor, and Oxygen sensor Heater. (see screen shot)

    The tuning file attached is the tune that was in the car for emissions, it should be OLSD, I think... lol I am not happy with my MainVE table yet, it is within 0-3% so it had to be good enough for now untill I pass emissions. If someone could take a peak at the tune and see if there is a reason why those tests wont be ready. I did the OBDIIGM Driving cycle thing like three times, and still no luck. The car has the mods in my sig, LT Headers, High Flow Cats, and 227/231 .614/.617 111+4 cam. I searched and tired everything I found and still no luck.

    System Readiness Tests: Click image for larger version. 

Name:	SRT.JPG 
Views:	149 
Size:	24.4 KB 
ID:	4176

    Tune: SDAutoVE_0007.5_Emissions_OLSD.tun

    Please let me know what you guys think! All input is appreciated!!!

    -CoryF
    2001 Camaro SS #2070
    -K&N FIPK, P/P TB, 227/231 .614/.617 111+4, UD Pulley, LT headers, OFY, Dumped 3" Exhaust, !AIR, KONI 4/4, Spec 3+ w/ Aluminum Fly Wheel, 4.10's, Custom EFILive Tune

  2. #2
    Lifetime Member mr.prick's Avatar
    Join Date
    Nov 2006
    Posts
    3,195

    Default

    Performing a GM OBD-II Driving Cycle:

    Cold Start.
    1. In order to be classified as a cold start the engine coolant temperature must be below 122°F (50°C) and within 11°F (6°C) of the ambient air temperature at startup. Do not leave the key on prior to the cold start or the heated oxygen sensor diagnostic may not run.

    Idle.
    2. The engine must be run for two and a half minutes with the air conditioner on and rear defroster on. The more electrical load you can apply the better. This will test the O2 heater, Passive Air, Purge "No Flow", Misfire and if closed loop is achieved, Fuel Trim.

    Accelerate.
    3. Turn off the air conditioner and all the other loads and apply half throttle until 55mph (88km/hr) is reached. During this time the Misfire, Fuel Trim, and Purge Flow diagnostics will be performed.

    Hold Steady Speed.
    4. Hold a steady speed of 55mph (88km/hr) for 3 minutes. During this time the O2 response, air Intrusive, EGR, Purge, Misfire, and Fuel Trim diagnostics will be performed.

    Decelerate.
    5. Let off the accelerator pedal. Do not shift, touch the brake or clutch. It is important to let the vehicle coast along gradually slowing down to 20 mph (32km/hr). During this time the EGR, Purge and Fuel Trim diagnostics will be performed.

    Accelerate.
    6. Accelerate at 3/4 throttle until 55-60mph (88-96 km/hr). This will perform the same diagnostics as in step 3.

    Hold Steady Speed.
    7. Hold a steady speed of 55mph (88km/hr) for five minutes. During this time, in addition to the diagnostics performed in step 4, the catalyst monitor diagnostics will be performed. If the catalyst is marginal or the battery has been disconnected, it may take 5 complete driving cycles to determine the state of the catalyst.

    Decelerate.
    8. This will perform the same diagnostics as in step 5. Again, don't press the clutch or brakes or shift gears.
    512k RoadRunner Firmware 12.14R
    FlashScan V2 Bootblock V2.07.04 Firmware V2.07.22 EFILive V7.5.7 (Build 191) V8.2.1 (Build 181)
    LC-1 WBO2

    _________________________________________________

  3. #3
    Senior Member Sid447's Avatar
    Join Date
    Jul 2005
    Posts
    178

    Default

    The B3605

    table is a bit odd you might want to get that more in line with say a 2001 ZO6 table.
    There's also a few other tables that need different settings but at the end of the day you are going to struggle through most emissions tests with a cam that big.
    Last edited by Sid447; November 1st, 2008 at 04:05 AM.

  4. #4
    Lifetime Member mr.prick's Avatar
    Join Date
    Nov 2006
    Posts
    3,195

    Default

    in AZ he just needs to have no DTC`s and get the system readiness tests in order.
    he can clear the DTC`s himself and the drive cycle should get the system readiness tests right.
    Last edited by mr.prick; November 1st, 2008 at 05:17 AM.
    512k RoadRunner Firmware 12.14R
    FlashScan V2 Bootblock V2.07.04 Firmware V2.07.22 EFILive V7.5.7 (Build 191) V8.2.1 (Build 181)
    LC-1 WBO2

    _________________________________________________

  5. #5
    Member
    Join Date
    Dec 2007
    Posts
    61

    Default

    Quote Originally Posted by mr.prick View Post
    Performing a GM OBD-II Driving Cycle:
    I tried that like three times :( still nothin.

    I removed the AIR pump and the rear 02's when I did this I went into the tune and changed the following codes to "X: Not Reported" under the "Engine DTC Processing Enablers":
    P0137 HO2S Circuit Low Voltage Bank 1 Sensor 2
    P0138 HO2S Circuit High Voltage Bank 1 Sensor 2
    P0140 HO2S Circuit Insufficiency Activity Bank 1 Sensor 2
    P0141 HO2S Heater Circuit Bank 1 Sensor 2
    P0157 HO2S Circuit Low Voltage Bank 2 Sensor 2
    P0158 HO2S Circuit High Voltage Bank 2 Sensor 2
    P0160 HO2S Circuit Insufficiency Activity Bank 2 Sensor 2
    P0161 HO2S Heater Circuit Bank 2 Sensor 2
    P0420 Catalyst System Efficiency below threshold Bank 1
    P0430 Catalyst System Efficiency below threshold Bank 2
    P0410 AIR System
    P0412 AIR Solenoid relay control circuit
    P0418 AIR Pump Relay Control Circuit
    P1415 AIR System Bank 1
    P1416 AIR System Bank 2


    Is this right or will the tests never pass because the sensors are not getting all the data to pass the test?

    I also set those codes to "No MIL" under the "Engine DTC MIL Enablers".

    I'm thinking that maybe removing these codes has something to do with it be I don's know what to set em to.

    Sid447, The B3605 table is set like that for the AutoVE, the tutorial said to set those cells in that region to 1.00, I have a different map that i will load once the AutoVE is done.

    -CoryF

    -CoryF
    2001 Camaro SS #2070
    -K&N FIPK, P/P TB, 227/231 .614/.617 111+4, UD Pulley, LT headers, OFY, Dumped 3" Exhaust, !AIR, KONI 4/4, Spec 3+ w/ Aluminum Fly Wheel, 4.10's, Custom EFILive Tune

  6. #6
    Lifetime Member mr.prick's Avatar
    Join Date
    Nov 2006
    Posts
    3,195

    Default

    Quote Originally Posted by CoryF View Post
    I tried that like three times :( still nothin.

    I removed the AIR pump and the rear 02's
    i`m not sure but having no rear O2`s may be why the
    O2 readiness is not ok.
    do you have cat`s?
    if not they are ready.
    was purge ready after the drive cycle?
    512k RoadRunner Firmware 12.14R
    FlashScan V2 Bootblock V2.07.04 Firmware V2.07.22 EFILive V7.5.7 (Build 191) V8.2.1 (Build 181)
    LC-1 WBO2

    _________________________________________________

  7. #7
    Member
    Join Date
    Dec 2007
    Posts
    61

    Default

    Quote Originally Posted by mr.prick View Post
    do you have cat`s?
    Yes
    Quote Originally Posted by mr.prick View Post
    was purge ready after the drive cycle?
    No

    I originally planned on running catless but decided to throw em on at the exhaust shop. I am going to try to find some jack stands around here an get under there and see if they reach. Fingers crossed

    Anyone else running without cats and have a passing O2 Readiness test?

    In Arizona do all the readiness tests have to pass?

    -CoryF
    2001 Camaro SS #2070
    -K&N FIPK, P/P TB, 227/231 .614/.617 111+4, UD Pulley, LT headers, OFY, Dumped 3" Exhaust, !AIR, KONI 4/4, Spec 3+ w/ Aluminum Fly Wheel, 4.10's, Custom EFILive Tune

  8. #8
    Lifetime Member mr.prick's Avatar
    Join Date
    Nov 2006
    Posts
    3,195

    Default

    if you have cat`s why not have the rear o2`s?
    if you are running open loop change
    {B0505} Purge Canister Open Loop to Enable.
    i imagine no rear O2`s will be why the O2 readiness is unavailable.

    i live in Prescott and we don`t have emissions testing.
    512k RoadRunner Firmware 12.14R
    FlashScan V2 Bootblock V2.07.04 Firmware V2.07.22 EFILive V7.5.7 (Build 191) V8.2.1 (Build 181)
    LC-1 WBO2

    _________________________________________________

  9. #9
    Member
    Join Date
    Dec 2007
    Posts
    61

    Default

    YOUR SO LUCKY!!! lol

    I have the B0505 set to "Enable" and i am going to hook back up the Rear O2's this afternoon. Go from there.

    Thanks for all the help so far!

    -CoryF
    2001 Camaro SS #2070
    -K&N FIPK, P/P TB, 227/231 .614/.617 111+4, UD Pulley, LT headers, OFY, Dumped 3" Exhaust, !AIR, KONI 4/4, Spec 3+ w/ Aluminum Fly Wheel, 4.10's, Custom EFILive Tune

  10. #10
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,775

    Default

    Quote Originally Posted by CoryF View Post
    ...
    changed the following codes to "X: Not Reported" under the "Engine DTC Processing Enablers":
    P0137 HO2S Circuit Low Voltage Bank 1 Sensor 2
    P0138 HO2S Circuit High Voltage Bank 1 Sensor 2
    P0140 HO2S Circuit Insufficiency Activity Bank 1 Sensor 2
    P0141 HO2S Heater Circuit Bank 1 Sensor 2
    P0157 HO2S Circuit Low Voltage Bank 2 Sensor 2
    P0158 HO2S Circuit High Voltage Bank 2 Sensor 2
    P0160 HO2S Circuit Insufficiency Activity Bank 2 Sensor 2
    P0161 HO2S Heater Circuit Bank 2 Sensor 2
    P0420 Catalyst System Efficiency below threshold Bank 1
    P0430 Catalyst System Efficiency below threshold Bank 2
    P0410 AIR System
    P0412 AIR Solenoid relay control circuit
    P0418 AIR Pump Relay Control Circuit
    P1415 AIR System Bank 1
    P1416 AIR System Bank 2


    Is this right or will the tests never pass because the sensors are not getting all the data to pass the test?

    I also set those codes to "No MIL" under the "Engine DTC MIL Enablers".
    ...
    Cory, set those codes MIL Enablers back to "MIL".

    Last edited by joecar; November 1st, 2008 at 08:00 AM.

Page 1 of 2 12 LastLast

Similar Threads

  1. New emissions laws
    By GMPX in forum Lounge
    Replies: 11
    Last Post: June 5th, 2009, 04:33 AM
  2. RR is failing as soon as it tries to update realtime data
    By TFZ_Z06 in forum RoadRunner Real-Time PCM Emulator
    Replies: 35
    Last Post: April 25th, 2009, 12:25 PM
  3. Success with Dec 31st Update?
    By Goldfinger911 in forum FlashScan V2 BB Logging
    Replies: 8
    Last Post: January 4th, 2008, 10:06 AM
  4. Emissions codes?
    By NewV in forum Gen III V8 Specific
    Replies: 3
    Last Post: April 3rd, 2007, 02:29 PM
  5. emissions
    By ZL1Killa in forum General (Petrol, Gas, Ethanol)
    Replies: 39
    Last Post: March 28th, 2006, 08:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •